Re: [xep-support] ditype

From: Michael Sulyaev <>
Date: Mon May 12 2008 - 11:50:21 PDT

Dave Pawson wrote:
> File "/usr/lib/python2.5/", line 714, in ?
> from thread import stack_size
> ImportError: cannot import name stack_size
> I thought it should be using *your* python (2.4?)
> looks like its picking up my python?

Hello Dave,

That has happened to be an environment issue: particularly, PYTHONPATH
pointed to 2.5 libs.

So, here is a use-case and a fix: DiType 1.9 may fail to start on Linux
and FreeBSD, and if the trace shows a python2.5 error like the above,
unset PYTHONPATH in bin/ditype-server, bin/ditype and neighboring
scrips. DiType will work properly then.

Dave, many thanks for help!

Best regards,
Michael Sulyaev
(*) To unsubscribe, send a message with words 'unsubscribe xep-support'
in the body of the message to from the address
you are subscribed from.
(*) By using the Service, you expressly agree to these Terms of Service
Received on Mon May 12 12:49:10 2008

This archive was generated by hypermail 2.1.8 : Mon May 12 2008 - 12:49:15 PDT