[xep-support] Bug with xep-pdf-ownerpassword instruction corrupts Page numbers in the Adobe Reader.

From: Volodymyr Mykhailyk <Volodymyr.Mykhailyk@intelliarts.com>
Date: Mon Mar 16 2009 - 08:03:28 PST


recently we encounter issue with rendering of page numbers in Adobe
Reader. These page numbers located on the toolbar area - input box where
you can directly type the page number you want to go (screenshot attached).

screenshot of the page numbers problem
As you can see the page number is a junk character instead of roman
letters (i, ii, iii, etc) accordingly to the format attribute in the
page sequence.

These corrupted page numbers occurs as only we are setting
xep-pdf-ownerpassword processing instruction. We have seen this problem
on Xep 4.4 and Xep 4.9. Below you can find simple fo file that could be
used to reproduce this problem.

<?xml version="1.0" encoding="utf-8"?><?xep-pdf-ownerpassword
annotate,print,copy?><?xep-pdf-initial-zoom fit?>
<fo:root xmlns:fo="http://www.w3.org/1999/XSL/Format"
        <fo:simple-page-master master-name="TOC-odd-page">
        <fo:page-sequence-master master-name="toc-sequence">
master-reference="TOC-odd-page" odd-or-even="odd"/>
    <fo:page-sequence format="i" master-reference="toc-sequence">
        <fo:flow flow-name="xsl-region-body">

Thanks in advance
Looking forward to hear any reply

(*) To unsubscribe, send a message with words 'unsubscribe xep-support'
in the body of the message to majordomo@renderx.com from the address
you are subscribed from.
(*) By using the Service, you expressly agree to these Terms of Service http://www.renderx.com/terms-of-service.html
Received on Mon Mar 16 08:46:51 2009

This archive was generated by hypermail 2.1.8 : Mon Mar 16 2009 - 08:46:56 PST