Re: [xep-support] Another Arabic problem (diacritics)

From: Krister Wicksell <>
Date: Mon Aug 11 2008 - 00:04:59 PDT


The problem is not so simple so it will be fixed by just wrapping words.
If I have English text inside the Arabic text and parts of the text are
formatted with fo:inline tags the same problem occurs. I tried to
manually wrap the complete English text with bidi-override but that do
not work if the text contain more than one level of fo:inline.

I tested with a XSL-formatter from another company and that worked
without wrapping the words. It also rendered the diacritics correctly
without me having to change the font. So maybe the easiest way for me is
to recommend my customer to use the XSL-formatter from the other company.

You may download my example from

- The first phrase shows the problem with diacritics.
- The second and fourth phrase shows the problem with character order.
- The third phrase has a problem with a strange character occurring
before EN/IEC.

Best Regards
> to cure the problem, you could write a simple stylesheet that will
> wrap every word of this kind the way you want -- it's just a few lines
> in XSLT, isn't it?

(*) To unsubscribe, send a message with words 'unsubscribe xep-support'
in the body of the message to from the address
you are subscribed from.
(*) By using the Service, you expressly agree to these Terms of Service
Received on Mon Aug 11 01:01:03 2008

This archive was generated by hypermail 2.1.8 : Mon Aug 11 2008 - 01:01:08 PDT