[xep-support] PDF page numbers

From: Victor Mote <vic@portagepub.com>
Date: Thu Aug 23 2007 - 17:57:46 PDT

Hi All:

I am using lowercase Roman numerals as page numbers in the front-matter
portion of a book (format="i") that is being generated by XEP 4.10 into PDF
format. XEP correctly generates the page number in the displayed/printed
output. However, Acrobat and Acrobat Reader, versions 6, 7, and 8 all show,
in the page navigation portion of their user interfaces, the wrong,
unrelated characters there.
1. I have tried with and without PDF encryption.
2. I have tried with and without PDF filtering.
3. I have tried with CFF-style fonts and Base-14 fonts (in case it was an
encoding issue).
4. I have tried with and without the "pdf-unicode-annotations" option set.

The characters themselves appear to be random in their origin, but not
necessarily random in their sequence. So, page "i" will be different (for
the same set of configuration options) when I run it the second time than it
was for the first. The one I am looking at right now shows the following:
i =
ii = E
iii = E/
iv = Z
v = 

You can see that the correct quantity of characters are appearing.
Interestingly, the value is correct in the XEP "intermediate" area tree
format. I can also see that the XSL-FO 1.1 PDF, generated by XEP, shows
these page numbers correctly, but it was built with XEP 4.5. Is there a bug
in the PDF renderer here, or am I missing some configuration option that I
need to set?

Thanks in advance for your help.

Victor Mote

-------------------
(*) To unsubscribe, send a message with words 'unsubscribe xep-support'
in the body of the message to majordomo@renderx.com from the address
you are subscribed from.
(*) By using the Service, you expressly agree to these Terms of Service http://www.renderx.com/terms-of-service.html
Received on Thu Aug 23 18:35:32 2007

This archive was generated by hypermail 2.1.8 : Thu Aug 23 2007 - 18:35:33 PDT